Introduction

Created with the Personal Edition of HelpNDoc: Full-featured EBook editor

Copyright © 2022 by HADD. All Rights Reserved.


Presentation of PM-SERVICE

Introduction ››

Help version 1.1

PM-SERVICE is a program for processing the results of measurements made by the Pulsometer PM21.

Communicates with the Pulsometer via a Bluetooth connection.

  • sets the time on the Pulsometer
  • downloads the measurement results and saves them to disk
  • evaluates the pulsator according to selected criteria
  • prints selected numerical results and / or waveforms
  • exports numerical results in csv format

In the Pulsometer, each measurement result consists of the numerical values of the measured parameters and a graph. The result is marked with the exact time the measurement was made.

Created with the Personal Edition of HelpNDoc: Write EPub books for the iPad


Working with PM-SERVICE

The program includes PM cards, PC cards and criteria.

The PM card is active when THERE IS a connection between the Pulsometer and the PC.

The PC card is active when there is NO connection between the Pulsometer and the PC.

The criteria card is ALWAYS active.

Created with the Personal Edition of HelpNDoc: Qt Help documentation made easy


Connecting with the Pulsometer

Working with PM-SERVICE ››

To connect the PC with the Pulsometer, press and hold the ON key on the Pulsometer until the following message is displayed:

and then start the PM-SERVICE program on the computer (the sequence is important).

As a result of trying to connect, the Pulsometer may display information:

and on the computer screen the following window may appear:

When there is no connection with the Pulsometer, the PC card , is active, which allows you to work with previously downloaded data.

If the connection is successful, the Pulsometer will display the following message:

The PM card becomes active and a window with the current settings of the connected Pulsometer appears on the computer screen.

Created with the Personal Edition of HelpNDoc: Free help authoring environment


Pairing PM with PC

Working with PM-SERVICE ›› Connecting with the Pulsometer ››

A new Pulsometer unknown to the computer must be paired with the computer.

To do this, press and hold the ON key on the Pulsometer until the following message appears:

but do not turn on the PM-SERVICE program.

The Pulsometer is ready to be seen by the computer, and as a result, ready to pair.

On the computer, start "Add a Bluetooth-enabled device".

The computer will find the Pulsometer called e.g. PM-212803, it will ask for a connection pin code. Enter 1234

The PM-212803 Pulsometer will be seen by Windows.

In order for the Pulsometer to be seen and operated by the PM-SERVICE software, it must be licensed. .

Created with the Personal Edition of HelpNDoc: Full-featured multi-format Help generator


The PM card

Working with PM-SERVICE ››

The PM card is active when there is a connection to the PM (via BlueTooth).

The PM card enables remote operation of the Pulsometer.

Created with the Personal Edition of HelpNDoc: Easily create HTML Help documents


Results

Working with PM-SERVICE ›› The PM card ››

Measurement results can be sent to the computer or deleted (deletion is also possible in the Pulsometer).

Created with the Personal Edition of HelpNDoc: Free Qt Help documentation generator


Settings

Working with PM-SERVICE ›› The PM card ››

The current settings of the connected Pulsometer.

Time, measurement reset and switch-off time are also available in the Pulsometer.

This window also appears immediately after connecting to the Pulsometer.

Created with the Personal Edition of HelpNDoc: Free HTML Help documentation generator


Turns off the Pulsometer

Working with PM-SERVICE ›› The PM card ››

Turns off the Pulsometer.

You can break the connection with the Pulsometer and go to the PC card to view the downloaded data.

Created with the Personal Edition of HelpNDoc: Easy EBook and documentation generator


View the Pulsometer

Working with PM-SERVICE ›› The PM card ››

When you choose to view the Pulsometer:

And here is the effect of monitoring the work of the Pulsometer when measuring the pulsator

The pulsator can be assessed according to given criteria

Created with the Personal Edition of HelpNDoc: Generate EPub eBooks with ease


The PC card

Working with PM-SERVICE ››

The PC card is active when there is no connection to the Pulsometer.

The PC card allows you to display (both in numerical and waveform) the measurement results stored in the Pulsometer.

Measurement results can be assessed, selected according to criteria, sent (numerical data) to a csv file, and printed.

Below the PC card menu.

Created with the Personal Edition of HelpNDoc: Easy to use tool to create HTML Help files and Help web sites


The results

Working with PM-SERVICE ›› The PC card ››

Select one from the catalog of saved sets:

After selecting the set, evaluate the pulsators and watch the course of the indicated measurement.

Selected measurements can be saved as a new set under any name.

Selected measurements can be printed, and the print preview can also be used:

Created with the Personal Edition of HelpNDoc: Easily create iPhone documentation


PM licenses

Working with PM-SERVICE ›› The PC card ››

Pulsometers to be operated by the computer must have the "_PC" license.

Pulsometers to use the attached printer must have the "_PRN" license.

The "_PC" license of the Pulsometer allows it to be operated by any number of computers (eg at work and at home).

The license "_PRN" of the Pulsometer allows you to activate the use of the printer.

This tab shows a list of Pulsometers with licenses registered on this computer.

You can add another Pulsometer with licenses (you must be connected to the internet)

If the Pulsometer with the specified serial number has a license, it will be added to the list.

The new Pulsometer must also be paired with the computer.

Created with the Personal Edition of HelpNDoc: Produce electronic books easily


Criteria card

Working with PM-SERVICE ››

The pulsator evaluation criteria card allows to define the features of the environment in which the pulsators operate..

The evaluation criteria can be used when viewing the pulsometer or analyzing a set of measurements.

Created with the Personal Edition of HelpNDoc: Full-featured Documentation generator